IT入门 > 教程 > vue教程 >
  • 更新node模块

    2019/05/04 点击:2861

    npm update 模块名 //当然你也可以update 该模块到指定版本 npm update 模块名 @版本号 //如果安装到最新版本可以使用以下命令 npm install 模块名@latest //如果当前的版本号为2.5.1,是没办法进行

  • 卸载模块

    2019/05/04 点击:4107

    卸载 模块 npm uninstall 模块名 看当前已经安装的模块 查 npm list //当然我们也可以限制输入的模块层级,例如 npm list --depth=0

  • 初始化项目

    2019/05/04 点击:4116

    npm init:引导你创建一个package.json文件,包括名称、版本、作者息 npm init//引导你创建一个package.json文件,包括名称、版本、作者这些信息

  • 版本控制

    2019/05/04 点击:7305

    默认情况下,当用--save或者--save-dev安装一个模块时,npm通过脱字符(^)来限定所安装模块的主版本号,而该脱字符对于不同的版本号有不同的更新机制 ^1.2.1 代表的更新版本范围为 >=1.2

  • cnpm

    2019/05/04 点击:2478

    你可以使用我们定制的 cnpm 命令行工具代替默认的 npm: 服务器在国内,比npm下载速度快 安装cnpm npm install -g cnpm --registry=https://registry.npm.taobao.org 使用cnpm cnpm install jquery// 使用cnpm 安装 j

  • yarn

    2019/05/04 点击:3282

    现在越来越多的项目开始使用yarn来替代npm ,yarn比npm要快些,也要稳定些 快速、可靠、安全的依赖管理工具。 Yarn 是 Facebook, Google, Exponent 和 Tilde 开发的一款新的 JavaScript 包管理工具。

  • yarn 安装模块

    2019/05/04 点击:7446

    yarn add [pkg-name] ,会自动安装最新版本,会覆盖指定版本号# yarn add jquery一次性添加多个包:yarn add [pkg-name1] [pkg-name2]# yarn add bootstrap zepto添加指定版本的包:yarn add [pkg-name]@ver# yarn add

  • yarn 更新模块

    2019/05/04 点击:16537

    将包更新到指定版本: yarn upgrade [pkg-name]@ver# jquery从2.1.4更新到3.0.0版本:yarn upgrade jquery@3.0.0将包更新到最新版本:yarn upgrade –latest [pkg-name]举例将3.0.0版本的 jquery更新到最新版本:y

  • 删除包

    2019/05/04 点击:1701

    yarn remove [pkg-name]举例删除 jquery:yarn remove jquery 一次删除多个包:yarn remove [pkg-name1] [pkg-name2] 举例删除 bootstrap 和 zepto:yarn remove bootstrap zepto

  • yarn.lock

    2019/05/04 点击:6642

    自动锁定安装包版本 在安装过程中,会自动生成一个 yarn.lock 文件,yarn.lock 会记录你安装的所有大大小小的。有点类似 PHP 开发者们所熟悉的 composer.lock。yarn.lock 锁定了安装包的精确版